Viper4android and Carplay

lightthief

Senior Member
Joined
Oct 17, 2015
Messages
570
Reaction score
177
Location
Cbus
Car(s)
2016 Black Civic Touring
Country flag
Has anyone successfully gotten Viper4android to work with CarPlay specifically?

Not Bluetooth and not Android Auto.
I’m able to get it to apply to Bluetooth audio perfectly well but CarPlay seems unaffected no matter what sources I choose.





Advertisement

 
OP

lightthief

Senior Member
Joined
Oct 17, 2015
Messages
570
Reaction score
177
Location
Cbus
Car(s)
2016 Black Civic Touring
Country flag
  • Thread starter
  • Thread Starter
  • #2
For anyone else trying to decide whether to buy Hondahack and wants to use Viper4android , after talking to a few people on different forums it looks like it’s doesn’t function with CarPlay.
 

MrWaYne

Senior Member
Joined
Jan 12, 2019
Messages
85
Reaction score
24
Location
GER
Car(s)
Honda Civic X 1.5 VTC Sport Plus
Country flag
ipod as a source doesnt work with viper aswell.
has that something to do with some weird apple protocols?
 
OP

lightthief

Senior Member
Joined
Oct 17, 2015
Messages
570
Reaction score
177
Location
Cbus
Car(s)
2016 Black Civic Touring
Country flag
  • Thread starter
  • Thread Starter
  • #4
ipod as a source doesnt work with viper aswell.
has that something to do with some weird apple protocols?
It’s not entirely surprising. It’s just a generic android app. It wasn’t written with whatever methodology Apple requires in mind.
Just frustrating, since that’s the only reason I spent money and someone else posted saying it worked but when I messaged them they said they were wrong about that.
 

carrsteven

Senior Member
First Name
Steven
Joined
Sep 10, 2017
Messages
99
Reaction score
41
Location
Fort Worth, TX
Car(s)
2017 Civic SI, 2017 Civic EX-L, 2016 Civic EX
Country flag
Version 2.5.0.5 has a Lock Effect Mode option, set that to bluetooth. Then it will work with all audio by forcing all audio to run through the bluetooth codec.
 
OP

lightthief

Senior Member
Joined
Oct 17, 2015
Messages
570
Reaction score
177
Location
Cbus
Car(s)
2016 Black Civic Touring
Country flag
  • Thread starter
  • Thread Starter
  • #6
Version 2.5.0.5 has a Lock Effect Mode option, set that to bluetooth. Then it will work with all audio by forcing all audio to run through the bluetooth codec.
Are you just extrapolating from what should work based on Android Auto?
CarPlay is totally different.
This doesn't work.
 

carrsteven

Senior Member
First Name
Steven
Joined
Sep 10, 2017
Messages
99
Reaction score
41
Location
Fort Worth, TX
Car(s)
2017 Civic SI, 2017 Civic EX-L, 2016 Civic EX
Country flag
No, I'm using real life experience. My wife has an iphone and I've tested it with her phone using car play.
 
OP

lightthief

Senior Member
Joined
Oct 17, 2015
Messages
570
Reaction score
177
Location
Cbus
Car(s)
2016 Black Civic Touring
Country flag
  • Thread starter
  • Thread Starter
  • #8
I"ll give it a try in a bit here.
To be clear though.
Audio over bluetooth has always worked.
The issue is getting wired CarPlay audio to be affected.
I just don't know the version of V4A I have installed offhand. That's the only variable I can see that would be different.
You're the only person I"ve talked to that hasn't walked back their claim unfortunately.
So I'd love to be wrong.
 

wiley-coyote

Member
First Name
Tom
Joined
Jul 23, 2019
Messages
11
Reaction score
1
Location
Kaneohe, HI
Car(s)
2019 Civic Sport Touring Hatchback (FK7) Agean Blue
Vehicle Showcase
1
Country flag
I"ll give it a try in a bit here.
To be clear though.
Audio over bluetooth has always worked.
The issue is getting wired CarPlay audio to be affected.
I just don't know the version of V4A I have installed offhand. That's the only variable I can see that would be different.
You're the only person I"ve talked to that hasn't walked back their claim unfortunately.
So I'd love to be wrong.
I'm running V4A 2.5.0.5 and I could NOT get carplay to work. Locked on Bluetooth.
 

wiley-coyote

Member
First Name
Tom
Joined
Jul 23, 2019
Messages
11
Reaction score
1
Location
Kaneohe, HI
Car(s)
2019 Civic Sport Touring Hatchback (FK7) Agean Blue
Vehicle Showcase
1
Country flag
I'm running V4A 2.5.0.5 and I could NOT get carplay to work. Locked on Bluetooth.
With the lock turned off, V4A shows that its connecting to the speaker, when I plug in my iPhone for Carplay. I have set up the speaker tab, but there isn't a noticeable difference in the audio quality. The only reliable way to get V4A to work is to use Bluetooth, in my experience.
 
OP

lightthief

Senior Member
Joined
Oct 17, 2015
Messages
570
Reaction score
177
Location
Cbus
Car(s)
2016 Black Civic Touring
Country flag
  • Thread starter
  • Thread Starter
  • #11
With the lock turned off, V4A shows that its connecting to the speaker, when I plug in my iPhone for Carplay. I have set up the speaker tab, but there isn't a noticeable difference in the audio quality. The only reliable way to get V4A to work is to use Bluetooth, in my experience.
That was my experience as well. I need to reinstall Honda hack and am having an issue so I can’t test again at the moment.
 

wiley-coyote

Member
First Name
Tom
Joined
Jul 23, 2019
Messages
11
Reaction score
1
Location
Kaneohe, HI
Car(s)
2019 Civic Sport Touring Hatchback (FK7) Agean Blue
Vehicle Showcase
1
Country flag
That was my experience as well. I need to reinstall Honda hack and am having an issue so I can’t test again at the moment.
I've started looking into jailbreaking my iPhone and using "Equalizer Everywhere" instead of dealing with V4A on the head-unit. What would be really cool is to have the something to plug before the amp for the adjustment of the bands. The FK7 ST has 8 speakers in great locations, but the audio frequency adjustment is [email protected]%t. The amp gets loud enough, just wish there was a way to adjust it. Enough crying...
 

WhiteSi

Member
Joined
Jun 26, 2019
Messages
44
Reaction score
28
Location
Georgia
Car(s)
2019 Civic Si
Country flag
One other bonus is to set the Iphone on "Loudness" EQ mode.
This gives that little bit more oomph with V4A.
Still doesn't fix CarPlay, but I too will attempt Lock to "Bluetooth" this weekend.
 

VMODE

Member
Joined
Nov 11, 2016
Messages
15
Reaction score
4
Location
norcal
Car(s)
2017 hatch st
Country flag
Does changing the music effects in settings not work?
I tested with my friends iphone for like 1 song via carplay and it seemed like the V4A settings were still active.
Pull down notifications > settings > sound > music effects > viper4androidfx

IMG_20190929_135723.jpg
 
OP

lightthief

Senior Member
Joined
Oct 17, 2015
Messages
570
Reaction score
177
Location
Cbus
Car(s)
2016 Black Civic Touring
Country flag
  • Thread starter
  • Thread Starter
  • #15
Does changing the music effects in settings not work?
I tested with my friends iphone for like 1 song via carplay and it seemed like the V4A settings were still active.
Pull down notifications > settings > sound > music effects > viper4androidfx

IMG_20190929_135723.jpg
I was able to get Honda Hack up and running again.
Viper4Android and CarPlay does not work.
Even after selecting the Music Effects option and locking the output.
Bluetooth the on/off is a pronounced change.

If someone is absolutely certain please post a video of them turning the effect on and off and steps.
Thanks.
 

Advertisement






Advertisement
Top