Pull on highway feels like loosing power

kefi

oh shit waddup its dat boi
Joined
Jan 8, 2020
Messages
801
Reaction score
785
Location
Central Florida
Website
fk8.clinic
Car(s)
2018 Type R
Build Thread
Link
Country flag
This may sound like a noob move, and probably isn't your problem, but I'll tell it just for kicks. My DIY cold air intake came loose one time, the MAF sensor and all. Man, the car does not run well at all with the MAF disconnected. It did run though, which surprised me. I was so relieved when I saw what the problem was. Easy fix, but I was quite worried during that commute.
You know, for as much as I've fucked around with this platform, I've never tried running it without the MAF. The more you know. Now I wanna see what the datalogs look like with no MAF.



Advertisement


 

kefi

oh shit waddup its dat boi
Joined
Jan 8, 2020
Messages
801
Reaction score
785
Location
Central Florida
Website
fk8.clinic
Car(s)
2018 Type R
Build Thread
Link
Country flag
I felt it after the downpipe install so im
Guessing after the 02 sensor has not been plugged in downpipe
As far as I know the secondary O2 sensor doesn't do anything except complain about catalytic efficiency. It won't pull power for that.

What's more likely happening is related to your fuel pump either being maxed out or dying, but I can't tell you that unless you go record a datalog and I look at it. You could also look at it yourself on KTuner's screen - DIFP shouldn't drop more than 15 bars from DIFPCMD (which should be 200) during a pull.
 
Last edited:
OP
415_CTR

415_CTR

Member
First Name
Felix
Joined
Jul 22, 2020
Messages
40
Reaction score
7
Location
Los Angeles
Car(s)
Fk8
Country flag
  • Thread starter
  • Thread Starter
  • #18
Car went into limp mode just now on the highway and got emission problem .. I am going to remove downpipe and get a deformed that fits and see if that fixes problem .. I think the o2 not being inserted downpipe is causing problem
 

kefi

oh shit waddup its dat boi
Joined
Jan 8, 2020
Messages
801
Reaction score
785
Location
Central Florida
Website
fk8.clinic
Car(s)
2018 Type R
Build Thread
Link
Country flag
Car went into limp mode just now on the highway and got emission problem .. I am going to remove downpipe and get a deformed that fits and see if that fixes problem .. I think the o2 not being inserted downpipe is causing problem
Instead of guessing and just swapping/buying parts, why don't you look at what the car computer is telling you like I've said a few times now?

If you got emissions problems on the dash, a check engine light was set and will tell you what's going on. A datalog during the pull will also tell you what's going on. Pull up what the code is on your KTuner.

You shouldn't be getting any CELs or limp mode for a catless downpipe if your tune is set up correctly, even if the SO2 is just hanging off or completely disconnected.
 
OP
415_CTR

415_CTR

Member
First Name
Felix
Joined
Jul 22, 2020
Messages
40
Reaction score
7
Location
Los Angeles
Car(s)
Fk8
Country flag
  • Thread starter
  • Thread Starter
  • #20
Instead of guessing and just swapping/buying parts, why don't you look at what the car computer is telling you like I've said a few times now?

If you got emissions problems on the dash, a check engine light was set and will tell you what's going on. A datalog during the pull will also tell you what's going on. Pull up what the code is on your KTuner.

You shouldn't be getting any CELs or limp mode for a catless downpipe if your tune is set up correctly, even if the SO2 is just hanging off or completely disconnected.
I’m not running v2 o tuner I’m on v1.. I’ll have to have it plugged into the computer ?
 

kefi

oh shit waddup its dat boi
Joined
Jan 8, 2020
Messages
801
Reaction score
785
Location
Central Florida
Website
fk8.clinic
Car(s)
2018 Type R
Build Thread
Link
Country flag

OrchidFc3

Senior Member
First Name
Holly
Joined
Mar 9, 2019
Messages
777
Reaction score
420
Location
New Brunswick Canada
Car(s)
2017 Civic Type R "EvilR" 1992 SI Turbo K20a2 1996 RHD ITR J Swap 2017 Civic LX Hatch
Build Thread
Link
Vehicle Showcase
1
Country flag
I’m not running v2 o tuner I’m on v1.. I’ll have to have it plugged into the computer ?
Yes you need your laptop for a V1, I have the same one. I am also running catless DP with zero issues on the 1.1 tune.
 

kefi

oh shit waddup its dat boi
Joined
Jan 8, 2020
Messages
801
Reaction score
785
Location
Central Florida
Website
fk8.clinic
Car(s)
2018 Type R
Build Thread
Link
Country flag
This came up .. then I redid it and the misfire light when away but the 02 lights stayed green

2EA04FC6-D326-4BD2-A1BF-4A4EC1B7B601.jpeg
The lights won't go back to green until you've driven around a bit, they're emissions monitors.

However.. P0229 was definitely not what I was expecting. That's a rare code that seemingly no one has ever asked about before on here. Did you do any work near the pedals? The ECU is reporting that there's a break or short in the throttle pedal position sensor or the wiring to it. This would also cause a sudden loss in power but is entirely unrelated to your downpipe.
 
OP
415_CTR

415_CTR

Member
First Name
Felix
Joined
Jul 22, 2020
Messages
40
Reaction score
7
Location
Los Angeles
Car(s)
Fk8
Country flag
  • Thread starter
  • Thread Starter
  • #27
The lights won't go back to green until you've driven around a bit, they're emissions monitors.

However.. P0229 was definitely not what I was expecting. That's a rare code that seemingly no one has ever asked about before on here. Did you do any work near the pedals? The ECU is reporting that there's a break or short in the throttle pedal position sensor or the wiring to it. This would also cause a sudden loss in power but is entirely unrelated to your downpipe.
No I have not done no work to pedals or near them this type r is giving me so many problems lol .. I’m new to k tuner so it means the red lights are the ones triggering the codes or the green ones
 
OP
415_CTR

415_CTR

Member
First Name
Felix
Joined
Jul 22, 2020
Messages
40
Reaction score
7
Location
Los Angeles
Car(s)
Fk8
Country flag
  • Thread starter
  • Thread Starter
  • #28
The lights won't go back to green until you've driven around a bit, they're emissions monitors.

However.. P0229 was definitely not what I was expecting. That's a rare code that seemingly no one has ever asked about before on here. Did you do any work near the pedals? The ECU is reporting that there's a break or short in the throttle pedal position sensor or the wiring to it. This would also cause a sudden loss in power but is entirely unrelated to your downpipe.
idk if it can be related butwhen I drive I get a weird rattle static sound from behind center console .. can it be maybe an electrical problem?
 

kefi

oh shit waddup its dat boi
Joined
Jan 8, 2020
Messages
801
Reaction score
785
Location
Central Florida
Website
fk8.clinic
Car(s)
2018 Type R
Build Thread
Link
Country flag
No I have not done no work to pedals or near them this type r is giving me so many problems lol .. I’m new to k tuner so it means the red lights are the ones triggering the codes or the green ones
It's not that the lights are triggering the codes, it's actually the other way around. The 'lights' represent certain emissions systems checks that states like California check for. If it's green, the check has passed and is 'ready'. If it's red, it hasn't passed yet or has an error. If it's gray, that means you disabled a CEL that will prevent it from ever being ready.

idk if it can be related butwhen I drive I get a weird rattle static sound from behind center console .. can it be maybe an electrical problem?
There's a lot of weird rattles in this car so that doesn't really mean much. It's almost certainly an electrical problem though, the ECU is saying that. This is one of those things you should just take it into a dealership for.

Make sure you tell them that you got the P0229 code for the throttle pedal circuit, don't mention your downpipe or anything. Your tune and parts don't have anything to do with that sensor circuit and should not violate the warranty for it.

Be careful with the numbers - P0299 is boost related, P0229 (two twos) is throttle pedal circuit.
 
OP
415_CTR

415_CTR

Member
First Name
Felix
Joined
Jul 22, 2020
Messages
40
Reaction score
7
Location
Los Angeles
Car(s)
Fk8
Country flag
  • Thread starter
  • Thread Starter
  • #30
It's not that the lights are triggering the codes, it's actually the other way around. The 'lights' represent certain emissions systems checks that states like California check for. If it's green, the check has passed and is 'ready'. If it's red, it hasn't passed yet or has an error. If it's gray, that means you disabled a CEL that will prevent it from ever being ready.


There's a lot of weird rattles in this car so that doesn't really mean much. It's almost certainly an electrical problem though, the ECU is saying that. This is one of those things you should just take it into a dealership for.

Make sure you tell them that you got the P0229 code for the throttle pedal circuit, don't mention your downpipe or anything. Your tune and parts don't have anything to do with that sensor circuit and should not violate the warranty for it.

Be careful with the numbers - P0299 is boost related, P0229 (two twos) is throttle pedal circuit.
Thank you very much for you’re help .. I’m new to ktuner , that’s why I was asking so much ... yeah I’m not mentioning shit about mods lol
 

Advertisement












Advertisement


Top