Anyone else have issues with tunerview on their head unit disconnecting?

Honda_RacerX

Banned
Joined
Jul 1, 2019
Messages
541
Reaction score
397
Location
2001
Car(s)
2019 Si
Country flag
  • Thread starter
  • Banned
  • #1
I did the Honda hack and installed tunerview a few weeks ago. My issue is that it keeps disconnecting. It will stay connected for about 20 to 30 seconds then disconnect and freeze, then reconnect, then disconnect, etc. Its been like that since I installed it.

When I use the app on my phone I do not encounter this problem as it stays connected.





Advertisement

 

gtman

Senior Member
First Name
Mitch
Joined
Oct 27, 2015
Messages
9,866
Reaction score
12,637
Location
USA
Website
www.civicx.com
Car(s)
2017 Cosmic Blue EX-L Sedan
Vehicle Showcase
2
Country flag
When I had Hondata, their app was flawless with Honda Hack. With Tunerview, it simply won't connect or stay connected at all. Thankfully, I have the V2 and use that instead.
 

86salmon

It's Hedley, Hedley Lamarr!
Joined
Sep 26, 2018
Messages
1,304
Reaction score
1,659
Location
Chucktown, SC
Car(s)
2018 Civic si sedan, 2001 Nissan Frontier
Build Thread
Link
Vehicle Showcase
1
Country flag
Issues all of the time on my phone. Kindle fire hooks up pretty well
 

EdwarDallas

Senior Member
First Name
Edward
Joined
Oct 22, 2019
Messages
136
Reaction score
62
Location
Dallas, Texas
Car(s)
2020 Civic Si Sedan, 2016 HRV MT-6, 2015 Civic Si Sedan, 2010 Civic Si Coupe, 2004 Civic Si (EP3) AKA The Black Egg
Country flag
Mine (In my 2020 Civic Si Sedan) has an issue with initial connection where I have to unplug and then replug it in for it to be detected by Bluetooth. I usually do this right after I start my car so I don't have to fiddle with it again. But I feel each time it just makes the K-tuner unit a little less likely to connect well the next time or it degrades it fitment-wise.

If I switch to my LaneWatch camera and then back, or out of TuneView for anything else (Change the radio station, use Pandora or Waze app--whatever else), often times it does not reconnect or stay connected in the background. Then I have to unplug it and replug it again WHILE DRIVING for Bluetooth to detect it and usually I have to swipe and have it re-detect the Ktuner unit.

It's a Pain In The Ass.

Frustrating.

It should maintain it's Bluetooth connection in the background, I think.

Edward
 

JT Si

Senior Member
First Name
JT
Joined
Mar 17, 2019
Messages
1,077
Reaction score
883
Location
Willamette Valley
Car(s)
2018 MSM Civic Si
Country flag
Yep, me too. Very aggravated. I've minimized the effect by tweaking the Bluetooth retry delay and count but it still frequently continuously reconnects. Also frequently it will stop reading from the ktuner.
 

joshhjackson2112

Senior Member
First Name
Josh
Joined
Jul 3, 2018
Messages
715
Reaction score
440
Location
Raleigh, North Carolina
Car(s)
18' SI
Country flag
My tuner view freezes up too. Sometimes when it connects, all the gauges read 0. I can usually pull the menu from the left of the screen to press connect. Then I will have to scan for device. Select the ktuner Bluetooth when it pops up and hope it connects. I often have to do this several times before it gets right.
 

JT Si

Senior Member
First Name
JT
Joined
Mar 17, 2019
Messages
1,077
Reaction score
883
Location
Willamette Valley
Car(s)
2018 MSM Civic Si
Country flag
My tuner view freezes up too. Sometimes when it connects, all the gauges read 0. I can usually pull the menu from the left of the screen to press connect. Then I will have to scan for device. Select the ktuner Bluetooth when it pops up and hope it connects. I often have to do this several times before it gets right.
This, too. If I'm lucky, turning the lanewatch camera on and off will trigger it to connect without my having to fumble around with the headunit but sometimes it's just not enough.

I wish there was a better, more reliable option for an app. I don't want to keep a phone, tablet, or ktuner v2 in the car to add a theft risk.
 

Aguirre129

Member
First Name
Cristian
Joined
Jul 23, 2019
Messages
33
Reaction score
22
Location
NC
Car(s)
2018 Honda Civic Si
Vehicle Showcase
1
Country flag
I did the Honda hack and installed tunerview a few weeks ago. My issue is that it keeps disconnecting. It will stay connected for about 20 to 30 seconds then disconnect and freeze, then reconnect, then disconnect, etc. Its been like that since I installed it.

When I use the app on my phone I do not encounter this problem as it stays connected.

Mine does on a rare occasion. If you have Honda Hack (cant remember if you have to pay for the pro) you can map your buttons to switch to different apps on your screen. I have my up arrow set to Viper4Android and my bottom to TunerView. When it freezes I simply click on my up to change apps and then down to change back to Tunerview. This makes it reconnect without having to disconnect the device from the OBD2 port or having to mess with the screen while I am driving.
 

Advertisement






Advertisement
Top