9" Aftermarket Android Head Unit (Feature Overview / Installation)

naldy

Senior Member
First Name
mick
Joined
Sep 25, 2019
Messages
145
Reaction score
49
Location
Kansas City
Car(s)
2019 Honda Civic Sport Hatchback
Country flag
Figured out why the head unit kept turning off the reverse camera, as well as why it wouldn't do headlight auto-dim. Turns out I had the wrong CANBUS protocol selected. You have to use "Raise CRIDER", not "Simple/Rasie Civic/CRV". This also fixed the instrument cluster clock issue

That officially solves absolutely every single thing wrong with my PX6. I can finally go to sleep happy tonight lol





Advertisement

 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
176
Reaction score
72
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
Figured out why the head unit kept turning off the reverse camera, as well as why it wouldn't do headlight auto-dim. Turns out I had the wrong CANBUS protocol selected. You have to use "Raise CRIDER", not "Simple/Rasie Civic/CRV". This also fixed the instrument cluster clock issue

That officially solves absolutely every single thing wrong with my PX6. I can finally go to sleep happy tonight lol
That's awesome! Great news. My sound went away....and hasn't come back. Tried everything I can think of....but it won't return. I left a message for Navifly, but they are 12 hour+ out of sync with us. Am nervous it is going to be a hassle to return it, if it is indeed broken. Any thoughts...? You run into something like this before...?
 

naldy

Senior Member
First Name
mick
Joined
Sep 25, 2019
Messages
145
Reaction score
49
Location
Kansas City
Car(s)
2019 Honda Civic Sport Hatchback
Country flag
That's awesome! Great news. My sound went away....and hasn't come back. Tried everything I can think of....but it won't return. I left a message for Navifly, but they are 12 hour+ out of sync with us. Am nervous it is going to be a hassle to return it, if it is indeed broken. Any thoughts...? You run into something like this before...?
Honestly I'm not sure, I've never run into that before nor have I seen anyone else with that issue in here
 

lastbluesun

Senior Member
First Name
Michael
Joined
Jun 9, 2020
Messages
62
Reaction score
10
Location
Vienna, VA
Car(s)
Honda Civic 1.5L Hatchback LX
Country flag
Well....it should go to the place on your radio that says Radio Antenna amplifier. That is where mine goes....but that just might be 12Vdc....not sure. That location is on the black plug on my radio....not sure where yours is without a schematic.

Two things:
1. Find the schematic for your radio.....you can ask the seller...they might respond, or google your radio information....but that is a tough find.
2. You can wait for me to measure the voltage on my blue wire and see if it is 12Vdc...if it is then we can find a spot to connect yours on your harness.
These are the schematics I found. Sorry for the slow reply!

IMG_20201026_170415.jpg


IMG_20201026_170408.jpg


IMG_20201026_170356.jpg


IMG_20201026_170341.jpg
 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
176
Reaction score
72
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
Honestly I'm not sure, I've never run into that before nor have I seen anyone else with that issue in here
I got it working. it was a new set of speakers(JBL GX628) that made the amp in the radio stop working. not sure why. I put the original speakers back in and the radio started working. Swap them back to the JBL and would work for about 5 mins and the no sound. Oh well...back to stock!

EDIT: After thinking about it....the JBL speakers have a tweeter that have what looks to be a High Pass Filter capacitor to isolate the frequency. The ohms on both speakers were both about 3 ohms....so the only thing I can think is that the Amp that is built into the Radio could not handle that capacitance across it's output....it's a guess. Either way...I did not want to risk bypassing that capacitor and just sent them back to Amazon. Yes...they sounded better...especially in the upper frequency....the treble was outstanding as was the base...but only having that for 3 minutes is not worth the effort. :) Let me know if you have been able to install after market speakers on your M400....would like to know the model and part number....might upgrade later.

btw...I did get the sound deadening install last weekend...and man....what a difference that made...! Is no vibrating distortion at all, due to the hollow door frame. And is definitely more substantial and less road noise too. Took about an hour per door...and covered 90% of the space with only having to make a few small cuts.

1603814557789.png

1603814613837.png
 
Last edited:

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
176
Reaction score
72
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
These are the schematics I found. Sorry for the slow reply!

IMG_20201026_170415.jpg


IMG_20201026_170408.jpg


IMG_20201026_170356.jpg


IMG_20201026_170341.jpg
I checked and my blue wire is connected to pin 12....which is your A12 on the top picture...called "A12 Ant Power" This should make a dramatic difference in your station availability. See below mine is in the same spot.
1603895381838.png
 

lastbluesun

Senior Member
First Name
Michael
Joined
Jun 9, 2020
Messages
62
Reaction score
10
Location
Vienna, VA
Car(s)
Honda Civic 1.5L Hatchback LX
Country flag
I checked and my blue wire is connected to pin 12....which is your A12 on the top picture...called "A12 Ant Power" This should make a dramatic difference in your station availability. See below mine is in the same spot.
1603895381838.png
I feel so stupid for not noticing. Thanks so much for your help!!!
 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
176
Reaction score
72
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
Got here pretty quick going to be a fun weekend.
F09A6813-49B7-4E60-B24B-02B8C6A96627.jpeg
Great....!! It was so fun to install and troubleshoot mine. Got everything working now...and am going to change the Reverse Camera View this weekend. Right now it is this weird fish eyed view....and I am going to change it to the regular view. If it works, I will post directions.

Good Luck....!! If you run into any issues....and I don't respond quickly....send me an email to [email protected].
 

civic model x

Senior Member
Joined
Mar 24, 2018
Messages
159
Reaction score
85
Location
Bay area
Car(s)
Civic sport
Vehicle Showcase
1
Country flag
Thanks will do. Will probably start on it after work tonight. Good luck on the camera views. Ill probably start with tapping into the mic, then test the back up cam. Make a few calls and see if the internal mic even works. I’ll probably hide the gps antenna and the 4g antenna under the plastic piece above the gauges.
 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
176
Reaction score
72
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
Thanks will do. Will probably start on it after work tonight. Good luck on the camera views. Ill probably start with tapping into the mic, then test the back up cam. Make a few calls and see if the internal mic even works. I’ll probably hide the gps antenna and the 4g antenna under the plastic piece above the gauges.
Because I don't use the GPS nor the 4G, I just tucked it back behind the radio....but I still get good GPS reception. I use Apple CarPlay for navigation.

I left my mic in the upper left corner....and it is working great, so I doubt I mess with it right now.
 

long_meats

Senior Member
Joined
Oct 9, 2018
Messages
251
Reaction score
105
Location
Richmond VA
Car(s)
2017 Civic Coupe LX CVT
Country flag
Because I don't use the GPS nor the 4G, I just tucked it back behind the radio....but I still get good GPS reception. I use Apple CarPlay for navigation.

I left my mic in the upper left corner....and it is working great, so I doubt I mess with it right now.
It's so easy to string it through to beneath the panel above the steering wheel that you might as well do it so you know it'll get better signal in case you ever do need to use it.
 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
176
Reaction score
72
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
It's so easy to string it through to beneath the panel above the steering wheel that you might as well do it so you know it'll get better signal in case you ever do need to use it.
Yup....understand. I ran my mic up there to the left corner of my windshield. But my GPS worked fine behind the radio with no slow downs or connections issues. Is mainly just plastic above the radio anyway. But thank you for the follow-up....if it doesn't work, I will move it up and above the steering wheel.

Just can't believe how bright and vibrant this M400 is....wow....just Amazing coming from the crappy 5" display.
1604087790307.png
 

Advertisement






Advertisement
Top