9" Aftermarket Android Head Unit (Feature Overview / Installation)

btycda36

Member
First Name
Jeff
Joined
Mar 1, 2018
Messages
7
Reaction score
3
Location
North Miami, FL
Car(s)
2018 Civic Hatchback Sport
Country flag
All installed now!! M400 HU was surprisingly plug n play to connect. Only snag was getting to be in English instead Chinese lol. It powered right up instantly and all my steering wheel functions worked. So far I've only used the radio and blue tooth functions and they're just fine. I was able to connect the powered sub using the 2 RCAs labeled "Audio Out L/R" and works perfectly. No issues with the back up camera besides the grainy look of course. I used the yellow camera RCA. It even shows whatever door is open on the screen now :) I routed the mic to the left of my wheel next to the tire sensor button and it works great for calls. FYI: I only plugged one side of the CanBus and no issues at all. I will add more info (like Apple Carplay) when I have time to mess with it. Thanks to all who for the helpful information!
Pic 1.jpeg
Pic 2.jpeg
Pic 3.jpeg
Pic 4.jpeg
Pic 5.jpeg
Pic 6.jpeg
Pic 7.jpeg
Here are some pics of the process:



Advertisement


 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
115
Reaction score
30
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
All installed now!! M400 HU was surprisingly plug n play to connect. Only snag was getting to be in English instead Chinese lol. It powered right up instantly and all my steering wheel functions worked. So far I've only used the radio and blue tooth functions and they're just fine. I was able to connect the powered sub using the 2 RCAs labeled "Audio Out L/R" and works perfectly. No issues with the back up camera besides the grainy look of course. I used the yellow camera RCA. It even shows whatever door is open on the screen now :) I routed the mic to the left of my wheel next to the tire sensor button and it works great for calls. FYI: I only plugged one side of the CanBus and no issues at all. I will add more info (like Apple Carplay) when I have time to mess with it. Thanks to all who for the helpful information!
Pic 1.jpeg
Pic 2.jpeg
Pic 3.jpeg
Pic 4.jpeg
Pic 5.jpeg
Pic 6.jpeg
Pic 7.jpeg
Here are some pics of the process:
Looks amazing...! Great Job.....love the Sub.....does it sound good..?

So glad your back up camera is working....gives me hope to fix mine. Did you happen to snap a picture of the black connector on the left....? If you did, can you post that pic...? The ones you posted above are the same as Mine....so weird.

IF you get a chance....go to settings....go to Car Settings.....go to the bottom and go to Extra Settings. Password for that menu is 123456. Scroll to the bottom and select Car Model. Take a picture and let me know what the settings are there. You can hit cancel....and hit the back arrow on the top of the screen to exit there. In that Extra menu you can set a ton of settings for the car and the head unit.

Wow.....I just noticed something.....you have an Automatic! I have a Stick....I wonder if that is the issue....that the CANBUS doesn't see me go into reverse because that mechanism is totally different.

Naldy.....do you have a Stick...?
 

btycda36

Member
First Name
Jeff
Joined
Mar 1, 2018
Messages
7
Reaction score
3
Location
North Miami, FL
Car(s)
2018 Civic Hatchback Sport
Country flag
Looks amazing...! Great Job.....love the Sub.....does it sound good..?

So glad your back up camera is working....gives me hope to fix mine. Did you happen to snap a picture of the black connector on the left....? If you did, can you post that pic...? The ones you posted above are the same as Mine....so weird.

IF you get a chance....go to settings....go to Car Settings.....go to the bottom and go to Extra Settings. Password for that menu is 123456. Scroll to the bottom and select Car Model. Take a picture and let me know what the settings are there. You can hit cancel....and hit the back arrow on the top of the screen to exit there. In that Extra menu you can set a ton of settings for the car and the head unit.

Wow.....I just noticed something.....you have an Automatic! I have a Stick....I wonder if that is the issue....that the CANBUS doesn't see me go into reverse because that mechanism is totally different.

Naldy.....do you have a Stick...?
Thanks! Unfortunately Those are the only pics I took. Same pics... great minds, lol!

Thanks for the info on how to get to that menu. I will be trying out the settings tomorrow. I'm sure I'll be spending awhile getting used to all of the functions.

The sub sounds great for it's compact size. I was quite impressed with it! Although, the little time I drove it today, it was weird having my butt vibrate lol. I kept the cables long just in case and will most likely relocate it to the trunk area.

Yes, mine is 2018 sport hatchback with the CVT. I was able to get the parking assist lines to show as well with the reverse camera.
 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
115
Reaction score
30
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
Thanks! Unfortunately Those are the only pics I took. Same pics... great minds, lol!

Thanks for the info on how to get to that menu. I will be trying out the settings tomorrow. I'm sure I'll be spending awhile getting used to all of the functions.

The sub sounds great for it's compact size. I was quite impressed with it! Although, the little time I drove it today, it was weird having my butt vibrate lol. I kept the cables long just in case and will most likely relocate it to the trunk area.

Yes, mine is 2018 sport hatchback with the CVT. I was able to get the parking assist lines to show as well with the reverse camera.
Hahahaha...that's funny. No problem. Let me know what you find in there. I am now looking at trying to find the wiring diagram...and am going to try to bypass the canbus and put the reverse directly into the head unit.
 

milhousesdad

Member
Joined
Jun 3, 2020
Messages
18
Reaction score
1
Location
NV
Car(s)
2019 Honda Civic Sport hatch
Country flag
I made a mistake and uninstalled "tlink" and tried to install zlink because I've heard it's better and now I cant get tlink back and zlink wont work im an idiot - if anyone has T Link and is able to upload the apk on here ill kiss you
 
Last edited:

JayDee

Member
First Name
Jose
Joined
May 26, 2020
Messages
21
Reaction score
3
Location
Miami
Car(s)
2018 Honda Civic Sport Hatchback 6MT & 1995 Honda Civic CX Hatchback
Country flag
QUOTE= @panda_fk7 The phoenix headunit has 2nd video input for lanewatch, so you will not lose the lanewatch function
—————-
I have a 2018 sport hatch with the base model screen and no lane watch.. but I’ve had an idea with this aftermarket head unit, in regards to the video input it has for the lane watch... I’m guessing it displays the lane watch camera when it receives a signal? Anyways my point is, I’ve thought about modifying my factory side mirrors with a camera, but unlike the factory lane watch which only has a camera on the right, I’d like one on each.. now there is only one video input for the lane watch, but an easy 1 to 2 splitter could do the job.. what id like to do is have 2 cameras, one on each side mirror, and when i put the turn signal, it displays the side that I’m turning to... i am not worried about wiring or the mirror/ camera modification, so don’t mention that.. i just want to know if it could work.. maybe someone who has a base model but upgraded their side mirror to the lane watch mirror and uses this? As long as it works with one, it should work with two as well..? Plz help :)
 

naldy

Senior Member
First Name
mick
Joined
Sep 25, 2019
Messages
122
Reaction score
40
Location
Kansas City
Car(s)
2019 Honda Civic Sport Hatchback
Country flag
I made a mistake and uninstalled "tlink" and tried to install zlink because I've heard it's better and now I cant get tlink back and zlink wont work im an idiot - if anyone has T Link and is able to upload the apk on here ill kiss you
Check your file manager, there might be a Tlink apk sitting in your system somewhere. @caldersm44 that's what I did when I did a factory reset, there was a folder called OEM where it housed all of the stock app apk files.

Also I drive a CVT
 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
115
Reaction score
30
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
FINALLY...!! Got the Reverse Camera working....Ugh! Much thanks to @btycda36 for posting his installation pictures. Led me down the road to conclude that all of you that have installed the M400 have CVT Automatics and not 6 Speed Manuals like me.

The issue stems from the fact that there is no reverse wire on the 6 Speeds tied into the wiring harness....so the Head Unit just didn't know that I put it into reverse. So after about 4 hours of searching non-stop....I ended back up on CivicX website.....where someone back in 2016 had installed an android radio with a 6 Speed Manual, and surprise....their camera didn't work. I knew that I needed to tie the reverse signal into the Head Unit....but didn't want to run a wire all the way back to the reverse lights...and I wasn't sure how to tie it into the Head Unit. But I figured it out after pouring over the all the different installations....there is a wire that comes off the battery....thru a fuse....then thru the switch under the manual transmission then out to the light in the back. That wire is under, luckily, the steering wheel to the left. And the M400 head unit takes the Reverse signal into wire on pin #3. So using T-taps....I ran a wire point to point and the rest is History...works like a charm..! See below the locations, if you have a 6 Speed Manual and a M400 Head Unit. Under the Steering wheel it is the far left green wire on the green connector. On the Radio...it is the pink wire.....3rd from the left on the top row looking down on the connector.

So one final question....Naldy.....in your Head Unit....can you adjust the display from Fisheye...? If so...let me know. If not...then I know how to do it with wiring....and will do that when my components come in. Let me know....and no need to take pictures....but appreciate all your help.

Reverse Light Wiring.jpg
Reverse Input Wiring.jpg
 

civic model x

Senior Member
Joined
Mar 24, 2018
Messages
105
Reaction score
52
Location
Bay area
Car(s)
Civic sport
Vehicle Showcase
1
Country flag
Glad you found it. Still waiting for mine. I already have my wire taps and rigged cable waiting to be installed for the mic. My subwoofer should just work since my underseat sub uses a built in loc. If it takes a month to get I have 3 more weeks to go till my m400 gets to me.
 

milhousesdad

Member
Joined
Jun 3, 2020
Messages
18
Reaction score
1
Location
NV
Car(s)
2019 Honda Civic Sport hatch
Country flag
Check your file manager, there might be a Tlink apk sitting in your system somewhere. @caldersm44 that's what I did when I did a factory reset, there was a folder called OEM where it housed all of the stock app apk files.

Also I drive a CVT
I was hoping it would be in there but I couldn't find it :( might have to buy another unit

and Navifly customer service sucks
 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
115
Reaction score
30
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
Found mine. Will copy to usb when I get back home and will post it
I was hoping it would be in there but I couldn't find it :( might have to buy another unit

and Navifly customer service sucks
Here is the one that is on mine. Had to zip it or it would let me upload the file. Let me know if it works for you.
 

Attachments

civic model x

Senior Member
Joined
Mar 24, 2018
Messages
105
Reaction score
52
Location
Bay area
Car(s)
Civic sport
Vehicle Showcase
1
Country flag
Think that will be the first thing I do once I get the m400 all hooked up is back up that oem folder. Or at least the apk default apps that were included. I would hate to loose the apps needed to run the system. This is what happens when you have full customize which is great but can be bad as the oem Honda head units won’t let you delete the default apps out since there locked down.
 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
115
Reaction score
30
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
Anyone have the issue where the sound just stops...? I took everything apart and no sound. Everything works....apple carplay....radio.....navigation....but just no sound. Am going to try and put the old head unit in and see if that one works.

I can hear the amp click when I reboot the radio...but no sound. Let me know if you have any ideas...am stumped.
 

Advertisement












Advertisement


Top