9" Aftermarket Android Head Unit (Feature Overview / Installation)

naldy

Senior Member
First Name
mick
Joined
Sep 25, 2019
Messages
137
Reaction score
45
Location
Kansas City
Car(s)
2019 Honda Civic Sport Hatchback
Country flag
Finally heard back from Navifly customer service. Here's the link to a set of instructions they sent me regarding Zlink Wireless Carplay setup/use as well as how to set up your Canbus on properly. I'm gonna give this a shot in half an hour.

Also as a general note, here are the menu passwords
1CA68642-3598-4776-A933-A24A581DFB61.png


@caldersm44 There're some wiring diagrams in here as well

Hopefully this helps anyone that's stuck from here on out

https://www.aliexpress.com/item/4001021728428.html?spm=a2g0s.imconversation.0.0.17e73e5f8AH3wp





Advertisement

 
Last edited:

naldy

Senior Member
First Name
mick
Joined
Sep 25, 2019
Messages
137
Reaction score
45
Location
Kansas City
Car(s)
2019 Honda Civic Sport Hatchback
Country flag
Finally heard back from Navifly customer service. Here's the link to a set of instructions they sent me regarding Zlink Wireless Carplay setup/use as well as how to set up your Canbus on properly. I'm gonna give this a shot in half an hour.

Also as a general note, here are the menu passwords
1CA68642-3598-4776-A933-A24A581DFB61.png


@caldersm44 There're some wiring diagrams in here as well

Hopefully this helps anyone that's stuck from here on out

https://www.aliexpress.com/item/4001021728428.html?spm=a2g0s.imconversation.0.0.17e73e5f8AH3wp
UPDATE: Canbus is now functioning. had to manually go in and find the right canbus protocol for my car.

so far this unit has been wayyy better than the Joying. kind of a bitch to set up but the UI looks way cleaner and i can actually listen to the radio without it cutting out every time i drive under a tree. carplay works great out of the box, enabling wireless takes an extra step.

only little quirk is that the instrument cluster clock no longer matches the head unit clock and unlike the Joying, there’s no way to change the time in there.

so far very happy with this purchase and i highly recommend it to anyone thinking about one of these. they’re on sale for $338 right now
 
Last edited:

KYRGYZ

Senior Member
Joined
Sep 25, 2016
Messages
812
Reaction score
277
Location
Bay Area
Car(s)
2016 Honda Civic LX, 2018 Nissan Rogue Sport, 2020 Honda Odyssey EX-L
Build Thread
Link
Country flag
Yeah I added it as it doesn't hurt to have it. I use it as an additional charger but will try with a usb stick as you can use that as additional storage for whatever. Also you should setup that tethering app - I stream stuff for trips with my daughter and works awesome and doesn't blow up your data plan.
extra USB comes with 4 pin, that port is 6 pin, did you just connect it there?
 

KYRGYZ

Senior Member
Joined
Sep 25, 2016
Messages
812
Reaction score
277
Location
Bay Area
Car(s)
2016 Honda Civic LX, 2018 Nissan Rogue Sport, 2020 Honda Odyssey EX-L
Build Thread
Link
Country flag
Is there a reason that you didn't connect your second USB port...? That is the 6 port connector. I see most people put it in the glove box. I think I am going to figure out how to surface mount it somewhere. They say you can add a USB flash drive with movies or other videos for the passenger to watch on long trips. Just wondering....no big deal.
1602591691016.png
First of all I had no idea where to plug 4 pin connector for extra USB, since all I left with is that 6 pin... and most likely I don't need any extra usb ports anyway, my Civic is just a "weekend" car if you wish, we don't take it to any road trips or long drives... less cables is better in my case :)
 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
146
Reaction score
50
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
UPDATE: Canbus is now functioning. had to manually go in and find the right canbus protocol for my car.

so far this unit has been wayyy better than the Joying. kind of a bitch to set up but the UI looks way cleaner and i can actually listen to the radio without it cutting out every time i drive under a tree. carplay works great out of the box, enabling wireless takes an extra step.

only little quirk is that the instrument cluster clock no longer matches the head unit clock and unlike the Joying, there’s no way to change the time in there.

so far very happy with this purchase and i highly recommend it to anyone thinking about one of these. they’re on sale for $338 right now
Great news! Congrats on the CANBUS. I have 6 SP Manual Hatch....so I don't believe the clock issue will affect me...maybe. LoL. I see they did drop the price to $338, but now they are charging $18 for standard shipping...and $42 for DHL. Still the best deal for $356 shipped compared to all other HU....especially with the RK3399 chipset. Mine was $218...now it is $193....guess they don't price match...?
<EDIT: I sent a message to NAVIFLY to see if they would price match the difference in cost....if not, I may return the M400 and get the PX6 unit....we will see. >
 
Last edited:

KYRGYZ

Senior Member
Joined
Sep 25, 2016
Messages
812
Reaction score
277
Location
Bay Area
Car(s)
2016 Honda Civic LX, 2018 Nissan Rogue Sport, 2020 Honda Odyssey EX-L
Build Thread
Link
Country flag
Hey I see your asking about which speakers you should use, someone linked the YouTube video on how to install speakers into the door panel and in the video the guy used Polk Db652 which you should buy on Crutchfield if they're available because they come with the harness to fit into the car. They're a big improvement. Makes the car bump a little harder but if you want something that shakes the ground you'll need a sub. I have Polk in the front and was going to put something in the rear but Ultimately decided that the rear speakers were not worth replacing unless your going to cut into the back and get something bigger than the oem ones.

VideoCapture_20201010-154342.jpg


VideoCapture_20201010-154348.jpg




20201010_154637.jpg
lol car specific harness can be bought anywhere from amazon to aliexpress, especially Honda, they didn't change speaker design since mid 00s... You can buy ANY speaker you want and buy wire adapter and speaker adapter for like $15 total... it doesn't have to be one specific brand
 

milhousesdad

Member
Joined
Jun 3, 2020
Messages
21
Reaction score
1
Location
NV
Car(s)
2019 Honda Civic Sport hatch
Country flag
I just got my m400 is it pretty much plug and play? and is "built in apple carplay" wireless or still plug in?
 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
146
Reaction score
50
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
I just got my m400 is it pretty much plug and play? and is "built in apple carplay" wireless or still plug in?
Am installing mine tomorrow....so we will find out. Due to the great guys on here that share their experiences....it should prove to be pretty easy. Am doing new speakers in the front and sound deadening tomorrow....so will report back and let you know.

The Carplay....according to this thread is Wired or Wireless.
 

naldy

Senior Member
First Name
mick
Joined
Sep 25, 2019
Messages
137
Reaction score
45
Location
Kansas City
Car(s)
2019 Honda Civic Sport Hatchback
Country flag
I just got my m400 is it pretty much plug and play? and is "built in apple carplay" wireless or still plug in?
it’s totally plug n play. as for apple carplay, it depends on which version of Zlink (the app that makes apple carplay work) is included with your system. on the M400 i believe it should do wireless carplay out of the box but if not you might need to go through the activation process
 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
146
Reaction score
50
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
it’s totally plug n play. as for apple carplay, it depends on which version of Zlink (the app that makes apple carplay work) is included with your system. on the M400 i believe it should do wireless carplay out of the box but if not you might need to go through the activation process
Ok....Have everything working now....thanks to Naldy about setting up the Wifi Tether with a manual IP connection....with no Router....that and a Reset did the trick. I can use the WIFI from my phone or Wireless Carplay via Tether. The issue for me was that the connection to the Tether of the HU had a different Subnet (third octet) when I connected to Wireless Carplay and tried to switch to the HU Apps that required WIFI. Since I was at my house....when Carplay dropped....my home WIFI gave me an IP address that was a different subnet and that confused the HU. So when I unlearned my home WIFI and used LTE for Data....everything went seamless.

Have to say....WOW.....this M400 vs the 5" Honda HU.....it's no competition! The M400 Bass is AMAZING....I basically had no sound in the old unit for the rear speakers....but now...WOW...is amazing. I have not even changed the speakers...and am debating whether I will...it is that good.

So...the only issue is the Backup camera. I believe it is because the Reverse wiring detection goes into the CANBUS....and I need to probably change the type. I went to Settings: Car Settings: Extra Settings: Password: 3368. But it doesn't do anything. I know I need to change it, but it doesn't work. Ugh. Let me know if you know of any other passwords. I tried 0000, 126, 3368. No luck.

Thanks for your help.
Steve
 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
146
Reaction score
50
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
Need some help.
1. Backup cam not working. Tried both cables. I know the cam is good because I plugged it into the AUX and I can see the picture....but when I reverse....it doesn't call up the backup screen. Is there a setting to enable?
2. how do u setup the iPhone to connect WiFi automatically? I keep having to reset it?
3. Can’t setup my google account. It says connecti g and just sits there This was because I had no WIFI after Carplay.
Ok...seems that Wireless Car Play is using WIFI. So when you are connected to CarPlay and want to go back to use say...Youtube....there is no WIFI connection to your car for data. It seems to mess up going back and forth....have to reset the HU. Getting frustrated. Wonder if you can use Zlink or Tlink...? I have Tlink. I would be happy to just use Wired Carplay and use WIFI for data stuff...but I can't seem to find Wired setting for Tlink. Anyone have any ideas.?


Ok....Have everything working now....thanks to Naldy about setting up the Wifi Tether with a manual IP connection....with no Router....that and a Reset did the trick. I can use the WIFI from my phone or Wireless Carplay via Tether. The issue for me was that the connection to the Tether of the HU had a different Subnet (third octet) when I connected to Wireless Carplay and tried to switch to the HU Apps that required WIFI. Since I was at my house....when Carplay dropped....my home WIFI gave me an IP address that was a different subnet and that confused the HU. So when I unlearned my home WIFI and used LTE for Data....everything went seamless.

Have to say....WOW.....this M400 vs the 5" Honda HU.....it's no competition! The M400 Bass is AMAZING....I basically had no sound in the old unit for the rear speakers....but now...WOW...is amazing. I have not even changed the speakers...and am debating whether I will...it is that good.

So...the only issue is the Backup camera. I believe it is because the Reverse wiring detection goes into the CANBUS....and I need to probably change the type. I went to Settings: Car Settings:
UPDATE: Canbus is now functioning. had to manually go in and find the right canbus protocol for my car.

so far this unit has been wayyy better than the Joying. kind of a bitch to set up but the UI looks way cleaner and i can actually listen to the radio without it cutting out every time i drive under a tree. carplay works great out of the box, enabling wireless takes an extra step.

only little quirk is that the instrument cluster clock no longer matches the head unit clock and unlike the Joying, there’s no way to change the time in there.

so far very happy with this purchase and i highly recommend it to anyone thinking about one of these. they’re on sale for $338 right now
What password did you use to get into the settings?
 

KYRGYZ

Senior Member
Joined
Sep 25, 2016
Messages
812
Reaction score
277
Location
Bay Area
Car(s)
2016 Honda Civic LX, 2018 Nissan Rogue Sport, 2020 Honda Odyssey EX-L
Build Thread
Link
Country flag
Ok....Have everything working now....thanks to Naldy about setting up the Wifi Tether with a manual IP connection....with no Router....that and a Reset did the trick. I can use the WIFI from my phone or Wireless Carplay via Tether. The issue for me was that the connection to the Tether of the HU had a different Subnet (third octet) when I connected to Wireless Carplay and tried to switch to the HU Apps that required WIFI. Since I was at my house....when Carplay dropped....my home WIFI gave me an IP address that was a different subnet and that confused the HU. So when I unlearned my home WIFI and used LTE for Data....everything went seamless.

Have to say....WOW.....this M400 vs the 5" Honda HU.....it's no competition! The M400 Bass is AMAZING....I basically had no sound in the old unit for the rear speakers....but now...WOW...is amazing. I have not even changed the speakers...and am debating whether I will...it is that good.

So...the only issue is the Backup camera. I believe it is because the Reverse wiring detection goes into the CANBUS....and I need to probably change the type. I went to Settings: Car Settings: Extra Settings: Password: 3368. But it doesn't do anything. I know I need to change it, but it doesn't work. Ugh. Let me know if you know of any other passwords. I tried 0000, 126, 3368. No luck.

Thanks for your help.
Steve
what issue with your reverse camera? this should be the connector for your camera

Screen Shot 2020-10-15 at 5.11.43 PM.png
 

caldersm44

Senior Member
First Name
Steve
Joined
Sep 14, 2019
Messages
146
Reaction score
50
Location
North Augusta, SC
Car(s)
2018 Civic Sport - 6 Speed
Country flag
what issue with your reverse camera? this should be the connector for your camera

Screen Shot 2020-10-15 at 5.11.43 PM.png
Yes...I am connected to that one. But it’s more of an issue with the reverse switch not being recognized by the canbus due to the model settings.
Can u check what your car model is setup as? Settings: Car Settings: Other Settings: Car Model. I have a sport manual and everything works but the reverse being recognized.
 

naldy

Senior Member
First Name
mick
Joined
Sep 25, 2019
Messages
137
Reaction score
45
Location
Kansas City
Car(s)
2019 Honda Civic Sport Hatchback
Country flag
What password did you use to get into the settings?
try 8806. and the reverse camera should work out of the box, you might have hooked it up wrong like i did at first but i’m not sure . there should be a cable coming from the canbus i think, and you plug the rear cam
 

Advertisement






Advertisement
Top